Skip to main content

View Post [edit]

Poster: الصوت الشيوعي Date: Nov 15, 2018 11:05pm
Forum: texts Subject: Failure to generate "__ia_thumb.jpg" file during upload of PDF with Arabic name

Hi.
Please look to my library:

https://archive.org/details/@user_16171

You see that certain PDF appear with correct book cover while other appear with Internet Archive icon as a book cover !

I discovered that this error (appearence of Internet Archive icon instead of correct book cover) is due to uploading PDF with Arabic name. If PDF uploaded is of latin name (English) no such error will happened because "__ia_thunb.jpg" will generated correctly. But if PDF to be uploaded is of Arabic name then "__ia_thunb.jpg" file will not generated !

Please is there way to correct this error or I should send a request to delete the affected pages & then re-create them from scratch ??

Please admin not ignore ! I searched FAQ & did not find any thing deal with this issue.

Reply [edit]

Poster: الصوت الشيوعي Date: Nov 18, 2018 2:46pm
Forum: texts Subject: Re: Failure to generate '__ia_thumb.jpg' file during upload of PDF with Arabic name

Hi ! I solve it !

Manage | checkout edit item files (non XML) | then re-name all posible files in Arabic to English.

I changed names into to be exactly as other non-editable files.

After deriving complete, the file not readable ! Only blank pages !

Now again go to Manage | checkout edit item files (non XML) | then DELETE a file with .jp2.zip extension then update & rederive. This will regenerate new .jp2.zip file with contents inside it ALL NAMED LATIN instead Arabic ! This will result in generation of ITEM TILE (ia__thumb) file & book cover will apear !

Please admin dectate this problem in FAQ because I saw many peples here complian from this & no one answer them !

Best.